Parcourir la source

bump version: btop-1.3.0

jcb il y a 4 mois
Parent
commit
071283691c
3 fichiers modifiés avec 33 ajouts et 1 suppressions
  1. 1 1
      README.md
  2. 2 0
      sys-process/btop/Manifest
  3. 30 0
      sys-process/btop/btop-1.3.0.ebuild

+ 1 - 1
README.md

@@ -21,6 +21,6 @@ Package list:
 * net-misc/ddgr                 - [2.1]              -- A command line utility to search DuckDuckGo from the terminal
 * net-misc/tuir                 - [1.29.0-r1]        -- A terminal user interface (TUI) for Reddit
 * net-p2p/bob-bin               - [9999]             -- B·o·B, an universal & secure peer-to-peer file-transfer (binary version)
-* sys-process/btop              - [1.2.8]            -- A complete monitor of machine resources
+* sys-process/btop              - [1.3.0]            -- A complete monitor of machine resources
 * x11-misc/find-cursor          - [1.8]              -- Simple XLib program to highlight the cursor position
 * x11-plugins/purple-discord    - [9999]             -- A libpurple/Pidgin plugin for Discord

+ 2 - 0
sys-process/btop/Manifest

@@ -1,4 +1,6 @@
 DIST btop-1.0.11.tar.gz 924227 BLAKE2B 3600c6ea82f8feefbb4c47dbcadab8bd28db00dfb844484b92b3379540e5f5663c1187a8b084b5adb55119534948c989fa2b4d2a9adb07dccfc8469abf3429f2 SHA512 94b2086b48ff9cad1af5ffcde8a1fe3c578bfdf590db3fd6778138ed1808c750ce90aa82c15c39accb77c8b50c880f6ce2e78f4eea03512a554964bf471674b2
 DIST btop-1.2.8.tar.gz 976370 BLAKE2B ab71ac322afd84b5b73c5deb9003f319078809d81e2725a7447d2a8fe7539af21c669e7199a3422b2a1cc2ecbd79a46179343e00311f2d56bfa30f51d6340bd3 SHA512 4b5a3685ca5cf301cd7d6556bd365892587e6811f8323ca66728022aba7cc3ff95cf591b452151c9431824dc458bc3d09e10474c7c02a944e8931c4585914f5a
+DIST btop-1.3.0.tar.gz 1142088 BLAKE2B 9f29828e646a8a4de2cacb8d5eb2885afbb5cf7764c9e4344f0da79b44c7481ca2591524789d753bc227f5a28c18717eda3aa3d1bb9f307f37e2732e9bbbde55 SHA512 0c20e3e1648dcf7d416e8f0072d40ed4b3e558eeb749150e4881d260cd675932c9b25315578e378f880172fe6470a8afc2687e011b491a79bd3e29618448f397
 EBUILD btop-1.0.11.ebuild 578 BLAKE2B 0bd843ba90a1cd71553b5c2120d4f023d5795c22c0ba3d9a8f31dad878bb308637344b06e76291ef049f8341cdf134a3d45bd915f6dae28b335c53cece51b1e4 SHA512 ed6ace5c3c307e12c9c680febcc9883693f271252d13f27726f28ae91d4c6a1834b7986d74358c463b65da74d43da08db08531c8a8e1a654b58af1bb373dc4d3
 EBUILD btop-1.2.8.ebuild 578 BLAKE2B 0bd843ba90a1cd71553b5c2120d4f023d5795c22c0ba3d9a8f31dad878bb308637344b06e76291ef049f8341cdf134a3d45bd915f6dae28b335c53cece51b1e4 SHA512 ed6ace5c3c307e12c9c680febcc9883693f271252d13f27726f28ae91d4c6a1834b7986d74358c463b65da74d43da08db08531c8a8e1a654b58af1bb373dc4d3
+EBUILD btop-1.3.0.ebuild 578 BLAKE2B 0bd843ba90a1cd71553b5c2120d4f023d5795c22c0ba3d9a8f31dad878bb308637344b06e76291ef049f8341cdf134a3d45bd915f6dae28b335c53cece51b1e4 SHA512 ed6ace5c3c307e12c9c680febcc9883693f271252d13f27726f28ae91d4c6a1834b7986d74358c463b65da74d43da08db08531c8a8e1a654b58af1bb373dc4d3

+ 30 - 0
sys-process/btop/btop-1.3.0.ebuild

@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A complete monitor of machine resources"
+HOMEPAGE="https://github.com/aristocratos/btop"
+SRC_URI="https://github.com/aristocratos/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=">=sys-devel/gcc-10"
+
+src_prepare() {
+	default
+}
+
+src_compile() {
+	emake 
+}
+
+src_install() {
+	emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+	dodoc README.md CHANGELOG.md
+}