Parcourir la source

add fire ebuild (dependency of colorpedia)

slash il y a 3 ans
Parent
commit
106a846675
2 fichiers modifiés avec 35 ajouts et 0 suppressions
  1. 2 0
      dev-python/fire/Manifest
  2. 33 0
      dev-python/fire/fire-0.4.0.ebuild

+ 2 - 0
dev-python/fire/Manifest

@@ -0,0 +1,2 @@
+DIST fire-0.4.0.tar.gz 87684 BLAKE2B 954de570e593b262468c6f9dabd25c2056a19c50037b91392a3305d455b0bc224a09b31071b86fbc490be5df5b42715412d62c624e3e3efe8d21e6db6c6c67f8 SHA512 d7c0a233a6deb700e597ef0d173e8c09c00eaa882c99f2390f85053e98e36a43113dca4d4e5b2bfcc92f39bda239df30670b17f120cac0fe7e9327320d90f1a8
+EBUILD fire-0.4.0.ebuild 657 BLAKE2B 7f0c63ac88ae63f2f7a9c018e7bc1c8733a1478123034b0d6bd1fd00a58787792cdeff14ec42e6e21283d984bf5855a7c52e4ee83407d3940f82ed9f6eb2c850 SHA512 a1995cb2ea9c63180f9929dfab97edb74875f17b9838fecd832cb5bb81ee0043e811f7c91e5257f88be0fabebfffdb9e1910bab703e0a7d78357484350407cc7

+ 33 - 0
dev-python/fire/fire-0.4.0.ebuild

@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Library for automatically generating CLIs with a single line of code"
+HOMEPAGE="https://github.com/google/python-fire"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+if [[ "${PV}" == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/google/python-fire"
+else
+	SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=( README.md )
+
+distutils_enable_tests setup.py
+
+src_install() {
+	distutils-r1_src_install
+}