Explorar el Código

add find-cursor ebuild

slash hace 3 años
padre
commit
4556e2aa7d

+ 3 - 0
x11-misc/find-cursor/Manifest

@@ -0,0 +1,3 @@
+AUX find-cursor-1.7-makefile-destdir.patch 215 BLAKE2B 5f5ea2c683aca62b8307634d429e696b9989683e3452c35c3d40735fd441b5caf624ae481cd3dfa7bb7223726ae71e32d956824f676afdfc98745bec3e4968b0 SHA512 fe2c59b6965afb53d49534dc8f66e23dfa3401df4ed502fd8a1cc39177f1647ac7cbdcc9ce9cfb24db7fd7c595f500ab2ce7d32b71af9443fb77c2b864f811b0
+DIST find-cursor-1.7.tar.gz 74521 BLAKE2B 827f0e81443fb18774bc04f1c6b7ecdfe411a330dc411113e674cfea982728707a116121ba17b3ce47cc5bca3463ba3cd36752a88e8bd18983e731abd320c059 SHA512 0973deb6d0828be7c9cfc5d833f773415fdb8edcd4bf36a2f19dcb45383d056babf244d6c40d1529882c1114cdb60c5bf80af3759b8beefe3811a2394edacf2c
+EBUILD find-cursor-1.7.ebuild 617 BLAKE2B 5d8b5ba7ab75244dfc0e8f1834a1c575a8f19d5282cf9efff53b9468246340c86fe09dc2daa5ca8cc92c60f39cc9e27766f268e1ddb63a82d9636a195d6d5d2e SHA512 5c2e84ee08044cdb73f6201be8557340382d2b6204346292b76db7a4022bc4c77e28758e517eb42c044b4903236382c6e0e68cff6f3f4c5a9be6c1633105cb42

+ 11 - 0
x11-misc/find-cursor/files/find-cursor-1.7-makefile-destdir.patch

@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ CC?=cc
+ CFLAGS?=-std=c99 -pedantic -Wall -Os
+-PREFIX?=/usr/local
++PREFIX?=/usr
+ 
+ all:
+ 	${CC} ${CFLAGS} ${LDFLAGS} -o find-cursor find-cursor.c -lX11 -lXext -lXfixes
+

+ 29 - 0
x11-misc/find-cursor/find-cursor-1.7.ebuild

@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple XLib program to highlight the cursor position"
+HOMEPAGE="https://github.com/arp242/find-cursor"
+SRC_URI="https://github.com/arp242/${PN}/archive/refs/tags/v${PV}.tar.gz  -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+	x11-libs/libXcomposite
+	x11-libs/libXdamage
+	x11-libs/libXrender
+	x11-libs/libX11"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+	eapply "${FILESDIR}"/${P}-makefile-destdir.patch
+	eapply_user
+}
+
+src_install() {
+	emake DESTDIR="${D}" install
+}