Parcourir la source

bump version: x11-misc/find-cursor-1.8

jcb il y a 1 an
Parent
commit
485e0cbdfc

+ 3 - 0
x11-misc/find-cursor/Manifest

@@ -1,3 +1,6 @@
 AUX find-cursor-1.7-makefile-destdir.patch 215 BLAKE2B 5f5ea2c683aca62b8307634d429e696b9989683e3452c35c3d40735fd441b5caf624ae481cd3dfa7bb7223726ae71e32d956824f676afdfc98745bec3e4968b0 SHA512 fe2c59b6965afb53d49534dc8f66e23dfa3401df4ed502fd8a1cc39177f1647ac7cbdcc9ce9cfb24db7fd7c595f500ab2ce7d32b71af9443fb77c2b864f811b0
+AUX find-cursor-1.8-makefile-destdir.patch 509 BLAKE2B b39f319f04c581530e43e77e75811c7e82d3105e1eec9426437c3c171586faf40f6b0ac633178396e01c4421bb62d57b420f6b6344f133f16f1c2a883aa81a87 SHA512 c4b2f91ba0c0b5e1d15a46d09347bd3ea0fe5e7059cbe5acd811459c4b56542a05dc570baa24cdf352a9b589a24193852be87f455c4a83a680401d78d2196b84
 DIST find-cursor-1.7.tar.gz 74521 BLAKE2B 827f0e81443fb18774bc04f1c6b7ecdfe411a330dc411113e674cfea982728707a116121ba17b3ce47cc5bca3463ba3cd36752a88e8bd18983e731abd320c059 SHA512 0973deb6d0828be7c9cfc5d833f773415fdb8edcd4bf36a2f19dcb45383d056babf244d6c40d1529882c1114cdb60c5bf80af3759b8beefe3811a2394edacf2c
+DIST find-cursor-1.8.tar.gz 74745 BLAKE2B 181561c973fbd31dc2f213b08b74a77a344f29ba92a0cb87fc8c503da719de494ece232966ff31d3ab4c8bca284f72f3529bdddc0ba64ae38ab1794daff2e4d9 SHA512 beeafc0ab87b0e5c8367da781e36eef7a1b7dad54cdedeab6fa0a95d986869be7b7a3c99ddd7d802a3d4dca1ae1364995a51abf9ceb9073ada30ec1dc4a06bc8
 EBUILD find-cursor-1.7.ebuild 617 BLAKE2B 5d8b5ba7ab75244dfc0e8f1834a1c575a8f19d5282cf9efff53b9468246340c86fe09dc2daa5ca8cc92c60f39cc9e27766f268e1ddb63a82d9636a195d6d5d2e SHA512 5c2e84ee08044cdb73f6201be8557340382d2b6204346292b76db7a4022bc4c77e28758e517eb42c044b4903236382c6e0e68cff6f3f4c5a9be6c1633105cb42
+EBUILD find-cursor-1.8.ebuild 617 BLAKE2B 5d8b5ba7ab75244dfc0e8f1834a1c575a8f19d5282cf9efff53b9468246340c86fe09dc2daa5ca8cc92c60f39cc9e27766f268e1ddb63a82d9636a195d6d5d2e SHA512 5c2e84ee08044cdb73f6201be8557340382d2b6204346292b76db7a4022bc4c77e28758e517eb42c044b4903236382c6e0e68cff6f3f4c5a9be6c1633105cb42

+ 20 - 0
x11-misc/find-cursor/files/find-cursor-1.8-makefile-destdir.patch

@@ -0,0 +1,20 @@
+--- a/Makefile	2022-07-12 11:48:18.488263029 +0200
++++ b/Makefile	2022-07-12 12:07:25.885165083 +0200
+@@ -1,14 +1,14 @@
+ CC      ?= cc
+-PREFIX  ?= /usr/local
++PREFIX  ?= /usr
+ NAME    ?= find-cursor
+ 
+ CFLAGS  += -std=c99 -pedantic -Wall -Wextra -Wpedantic -Os
+-LDFLAGS += -L/usr/lib -lX11 -lXext -lXfixes
++LIBS    += -lX11 -lXext -lXfixes
+ 
+ .PHONY: all clean install uninstall
+ 
+ all:
+-	${CC} ${CFLAGS} ${LDFLAGS} -o ${NAME} *.c
++	${CC} ${CFLAGS} ${LDFLAGS} -o ${NAME} *.c ${LIBS}
+ 
+ clean:
+ 	rm -f ${NAME}

+ 29 - 0
x11-misc/find-cursor/find-cursor-1.8.ebuild

@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple XLib program to highlight the cursor position"
+HOMEPAGE="https://github.com/arp242/find-cursor"
+SRC_URI="https://github.com/arp242/${PN}/archive/refs/tags/v${PV}.tar.gz  -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+	x11-libs/libXcomposite
+	x11-libs/libXdamage
+	x11-libs/libXrender
+	x11-libs/libX11"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+	eapply "${FILESDIR}"/${P}-makefile-destdir.patch
+	eapply_user
+}
+
+src_install() {
+	emake DESTDIR="${D}" install
+}