Parcourir la source

bump version: gpp-2-28

jcb il y a 4 mois
Parent
commit
62748b3401
3 fichiers modifiés avec 35 ajouts et 1 suppressions
  1. 1 1
      README.md
  2. 2 0
      app-text/gpp/Manifest
  3. 32 0
      app-text/gpp/gpp-2.28.ebuild

+ 1 - 1
README.md

@@ -5,7 +5,7 @@ Package list:
 * app-text/colorpedia           - [1.2.3-r4]         -- Command-line tool for looking up colors, shades and palettes
 * app-text/csv2ical             - [9999]             -- Converts a CSV file with event information to an iCalendar ICS file
 * app-text/epy                  - [2022.12.11-r1]    -- A fork of epr, a CLI Ebook Reader
-* app-text/gpp                  - [2.27]             -- General-purpose preprocessor with customizable syntax
+* app-text/gpp                  - [2.28]             -- General-purpose preprocessor with customizable syntax
 * app-text/ods2md               - [9999-r2]          -- Convert LibreOffice Spreadsheets (*.ods) into Markdown tables
 * app-text/papis                - [0.13-r1]          -- A powerful and highly extensible CLI document and bibliography manager
 * app-text/zaread               - [9999]             -- A (very) lightweight MS Office files reader

+ 2 - 0
app-text/gpp/Manifest

@@ -1,2 +1,4 @@
 DIST gpp-2.27.tar.gz 66226 BLAKE2B 18490dae11fa295c6a038c6de86919a9b37a10c6008490bd554f11e52916e92e80238bb858c799fa1345419a56b37f9f817cd9c8d0fe221bd8c51b3d12245fb1 SHA512 ad7eaf89796208668143c160bfe764d5b38fb734dfa29869d2b222ce4c1982e8f5eef679960645de51c7d4fda6a18cac4ded55334a62cd16698a42b89aebf71e
+DIST gpp-2.28.tar.gz 66655 BLAKE2B 5ac2fe6abfd623071139a5592d17a963889f566d568f2cb083a307bf60fc94ab528908a08ebdee4f0a7e4a40ca25ee0feb11bd218da9686b984e779e57641aff SHA512 725b521abeb768e06bc58a4c443c80e0aab65a74f4dfaa524399a9d71037d70e1790fed602ec22c3e7d3ffc788a0b03c4c37dd6f483758bf8b306b5d7ef3e493
 EBUILD gpp-2.27.ebuild 550 BLAKE2B 7063cda73177496b47e4ec98fd97aae3117503749ff81a75801d775f86b68fff8b40058b70e0d3579ac12f7df97ed733783fb9037decdfa9173106f35218170b SHA512 f831f62330b3040b73544e299871ea3532da770391cc515f846f4a1b2f29b96bc8647e915c53248e84051b09ae596806052e2d773bddbee730820f58f309f4eb
+EBUILD gpp-2.28.ebuild 550 BLAKE2B 7063cda73177496b47e4ec98fd97aae3117503749ff81a75801d775f86b68fff8b40058b70e0d3579ac12f7df97ed733783fb9037decdfa9173106f35218170b SHA512 f831f62330b3040b73544e299871ea3532da770391cc515f846f4a1b2f29b96bc8647e915c53248e84051b09ae596806052e2d773bddbee730820f58f309f4eb

+ 32 - 0
app-text/gpp/gpp-2.28.ebuild

@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="General-purpose preprocessor with customizable syntax"
+HOMEPAGE="https://logological.org/gpp"
+SRC_URI="https://github.com/logological/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+	eapply_user
+	eautoreconf
+}
+
+src_configure() {
+	econf
+}
+
+src_install() {
+	default
+	emake DESTDIR="${D}" install
+}