@@ -1,6 +1,7 @@
slash's personal overlay
Package list:
+* app-benchmarks/load-time - [9999] -- Program that mesures the time it takes to load a shared library
* app-text/baca - [0.1.17 & 9999] -- A TUI Ebook Reader
* app-text/colorpedia - [1.2.3-r4] -- Command-line tool for looking up colors, shades and palettes
* app-text/csv2ical - [9999] -- Converts a CSV file with event information to an iCalendar ICS file
@@ -0,0 +1 @@
+EBUILD load-time-9999.ebuild 575 BLAKE2B 493f02b69c3f94a5e1c1d2b198c3bcb655e2eb938c7af05a3e8415a00f2907d0e478d40fea7b9b5f8d14e20a363e33b3a705d9cdf96db318a19a237666ca888a SHA512 93409548255215a168992a09627d95ece247412c4d4f4cb03ef4da455115ddbdf9ef28e0268be51580b6e925c979ca13e2ac3984858731c96c5f233c894c4fda
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit git-r3
+DESCRIPTION="Program that mesures the time it takes to load a shared library"
+HOMEPAGE="https://github.com/serge-sans-paille/load-time"
+EGIT_REPO_URI="https://github.com/serge-sans-paille/${PN}"
+LICENSE="BSD-3-Clause"
+SLOT="0"
+KEYWORDS="~amd64"
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="sys-devel/gcc"
+DOCS=( README.rst LICENSE )
+src_prepare() {
+ default
+}
+src_compile() {
+ emake
+src_install() {
+ exeinto "/usr/bin"
+ doexe ${PN}
+ dodoc ${DOCS}