Parcourir la source

python-markdownify: bump version + fixes
* 0.11.6 -> 0.12.1
* python-markdownify issue #86 has been closed and solved, but it does
not solve the problem of test at the top-level directory. Therefore,
instead of removing tests/ (as in the last ebuild), we move it to
markdonify directory
* update Python compat

jcb il y a 4 mois
Parent
commit
802bee6056

+ 1 - 1
README.md

@@ -21,7 +21,7 @@ Package list:
 * dev-python/pyexcel-ezodf      - [0.3.4-r1]         -- Library to manipulate OpenDocument files (pyexcel version)
 * dev-python/pykdtree           - [1.3.11]           -- Fast kd-tree implementation with OpenMP-enabled queries
 * dev-python/python-doi         - [0.2]              -- Python package to work with Document Object Identifier (doi)
-* dev-python/python-markdownify - [0.11.6]           -- Library to convert HTML to Markdown 
+* dev-python/python-markdownify - [0.12.1]           -- Library to convert HTML to Markdown 
 * dev-python/textual            - [0.38.1]           -- Python framework to build sophisticated UI
 * games-strategy/unciv-bin      - [4.12.1]           -- Civ V remake for Android & Desktop
 * media-fonts/square            - [1.0]              -- A TTF font designed to make characters fill a square space

+ 2 - 0
dev-python/python-markdownify/Manifest

@@ -1,2 +1,4 @@
 DIST python-markdownify-0.11.6.tar.gz 13183 BLAKE2B a92c6db55076105a717f808fc42dff87249eb71e63ae3dc61afcb63409802b2848b25bccaf8f3ba517bfd6f9c196e55e66802337fad677cada1630d11a71815c SHA512 750996a28085dedefed3c89e2e264d32398c14449aa23837366c4b4e3a92a9ebe660c80c27f98ed1cb3240c47f8de872d46730ffe2452e436931e762a4dc9f02
+DIST python-markdownify-0.12.1.tar.gz 13936 BLAKE2B 9583f37d28fd90e348dd9ae1ed062f1f43d10e1631675f5e13a1f5971f4a9fcf42349fdfe71df3d70ec099f0e922f9a5f369988a91237d5777eaa0f8032e619d SHA512 bc79f2de9dfaa971953be94cc2dd2eff22ef2ab3aa11eb6dc5f157abad472a198ff1651248e37d4e7636fb41d7376cd4971f6fe4076922033cc4147c2f477137
 EBUILD python-markdownify-0.11.6.ebuild 906 BLAKE2B c78ea61ef0faaa2267c3aa265c6ccff333980fb1735210ebe083344ddb4ed881e2c2275e0b620b9b2f4190900b0e286bd5264c5caa8300d9aa137ad9331de174 SHA512 0a29da3b46a2730e88ec19ef9cd765bc4ad96a87687aa7859e36cab4c4d014b1f1c2efc53b0f2f845e61d5f7d0ea95d6c5d0d5b9fc54d787071c23f63993a35c
+EBUILD python-markdownify-0.12.1.ebuild 807 BLAKE2B fda1dc9d920b36d05029ecade2cfce5db5329d559fc53d8d0b187373c54b01d04d3b3022d03568c38b3fae25ba3e89960b8d7e9c9f19a8fbdf7c82d5c0ecc2cb SHA512 1ff019d2d513fe0deb3f6ac253dc4e1999815395654b1fd518efb4a4225ef3990b1c03ad47e9148cde6f4722e3bb4e0107d7f7a3820e0a4ec5edd34826aed695

+ 37 - 0
dev-python/python-markdownify/python-markdownify-0.12.1.ebuild

@@ -0,0 +1,37 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Library to convert HTML to Markdown"
+HOMEPAGE="
+	https://pypi.org/project/markdownify/
+	https://github.com/matthewwithanm/python-markdownify
+"
+SRC_URI="https://github.com/matthewwithanm/python-markdownify/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+	dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+	dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+DOCS=( README.rst MANIFEST.in LICENSE )
+
+python_prepare_all() {
+	mv tests markdownify/tests || die
+	distutils-r1_python_prepare_all
+}
+
+src_install() {
+	distutils-r1_src_install
+}