Browse Source

media-libs/libtxc_dxtn ebuild

jcb 2 years ago
parent
commit
822f430530
3 changed files with 33 additions and 0 deletions
  1. 1 0
      README.md
  2. 2 0
      media-libs/libtxc_dxtn/Manifest
  3. 30 0
      media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1.ebuild

+ 1 - 0
README.md

@@ -5,6 +5,7 @@ Package list:
 * app-text/gpp               -- Command-line tool for looking up colors, shades and palettes
 * dev-python/fire            -- Library for automatically generating CLIs with a single line of code
 * dev-python/kitchen         -- Useful snippets of code that everybody ends up writing for their projects
+* media-libs/libtxc_dxtn     -- Implementation of the S3 Texture Compression
 * net-misc/ddgr              -- A command line utility to search DuckDuckGo from the terminal
 * net-misc/tuir              -- A terminal user interface (TUI) for Reddit
 * sys-process/btop           -- A complete monitor of machine resources

+ 2 - 0
media-libs/libtxc_dxtn/Manifest

@@ -0,0 +1,2 @@
+DIST libtxc_dxtn-1.0.1.tar.bz2 214038 BLAKE2B a342bda7375dcbd4001adb5469c90a043fa039bc2505c9cf717613054b494fea9054136b25ac80b016c62aec248085a60ab5e71190cd5c2d90941bdda6408d16 SHA512 56714a8c947d9b1f47e3ccb23cff9e4e57bd131907a82968de521d094a000275b3aaeecff28e9184bcc4f3932baa1a8bfbbefbc970fcd034ff953d0617148479
+EBUILD libtxc_dxtn-1.0.1.ebuild 654 BLAKE2B 1997d8fd6e76393a0cb43f8ac6789d93d056dbc0ea62e65f7a3c54544f119ba8ba613b8b2e0ff20107cf3db829fa943ef9f2d9b09417e04292ba7af52d90c7e8 SHA512 85ca2acc6dd394c6ae7e9028427a2244f46254038f28e0fad31896962d4b6a4994fe886b39262d6f2752f6ebbf3df01c60441616d9312bad5fcd2a08eb3c4f57

+ 30 - 0
media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1.ebuild

@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="Implementation of the S3 Texture Compression"
+HOMEPAGE="https://web.archive.org/web/20200923055707/https://cgit.freedesktop.org/~mareko/libtxc_dxtn/"
+SRC_URI="https://people.freedesktop.org/~cbrill/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="media-libs/mesa"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+multilib_src_configure() {
+	ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+	default
+
+	# libtxc_dxtn is installed as a module (plugin)
+	find "${D}" -name '*.la' -delete || die
+}
+