Parcourir la source

cleaning: remove <dev-python/fire-0.6.0 ebuilds

jcb il y a 1 mois
Parent
commit
bef259bbce
2 fichiers modifiés avec 0 ajouts et 72 suppressions
  1. 0 33
      dev-python/fire/fire-0.4.0-r1.ebuild
  2. 0 39
      dev-python/fire/fire-0.5.0.ebuild

+ 0 - 33
dev-python/fire/fire-0.4.0-r1.ebuild

@@ -1,33 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9,10,11} )
-inherit distutils-r1
-
-DESCRIPTION="Library for automatically generating CLIs with a single line of code"
-HOMEPAGE="https://github.com/google/python-fire"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-if [[ "${PV}" == *9999 ]]; then
-	inherit git-r3
-	EGIT_REPO_URI="https://github.com/google/python-fire"
-else
-	SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-fi
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-BDEPEND=""
-
-DOCS=( README.md )
-
-distutils_enable_tests setup.py
-
-src_install() {
-	distutils-r1_src_install
-}

+ 0 - 39
dev-python/fire/fire-0.5.0.ebuild

@@ -1,39 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{10,11} )
-inherit distutils-r1
-
-MY_PN=python-${PN}
-MY_P=${MY_PN}-${PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Library for automatically generating CLIs with a single line of code"
-HOMEPAGE="
-	https://github.com/google/python-fire
-	https://pypi.org/project/fire/"
-
-if [[ "${PV}" == *9999 ]]; then
-	inherit git-r3
-	EGIT_REPO_URI="https://github.com/google/python-fire"
-else
-	SRC_URI="https://github.com/google/python-fire/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.tar.gz"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-BDEPEND=""
-
-DOCS=( README.md )
-
-distutils_enable_tests setup.py
-
-src_install() {
-	distutils-r1_src_install
-}