Explorar el Código

baca-0.1.16-r3 -> 0.1.16-r4: backport patch in order to be able to use CLImage-0.2.0 with baca-0.1.16 + mask live ebuild (baca-9999)

jcb hace 5 meses
padre
commit
c1ffaba5d3

+ 1 - 1
README.md

@@ -1,7 +1,7 @@
 slash's personal overlay
 
 Package list:
-* app-text/baca                 - [0.1.16-r3 & 9999] -- A TUI Ebook Reader
+* app-text/baca                 - [0.1.16-r4 & 9999] -- A TUI Ebook Reader
 * app-text/epy                  - [2022.12.11]       -- A fork of epr, a CLI Ebook Reader
 * app-text/colorpedia           - [1.2.3-r3]         -- General-purpose preprocessor with customizable syntax
 * app-text/ods2md               - [9999-r1]          -- Convert LibreOffice Spreadsheets (*.ods) into Markdown tables

+ 2 - 1
app-text/baca/Manifest

@@ -1,5 +1,6 @@
+AUX baca-0.1.16_with_CLImage-0.2.0.patch 774 BLAKE2B 209c59a069de06b03bb421cca674faf3df212b8e6bbf8fe8dd0645b4699eea52c30ad7937bbd7c7111ce272f99cf8530f529e4440e17f9f3ac47a7d54ef6cea7 SHA512 9969ba7de5d0923f5e0ee9946af1785d6fa85a9b2ccb30e9c5aa3dfdfd4a5b71c31bbbea851769e629a5e624a9c105e773fcc7708d28df0b049321ba838ce5d8
 DIST baca-0.1.16.tar.gz 151689 BLAKE2B 2a19f12eaaa1e35c01a88a38ff4343b4db179c728661e4631ae8ceeb1c25ae5d277978a09f499ee54b12a11a1dcf67c27e171c08a3ba9bc8d0181a9e94f4c284 SHA512 386c0df32761344d4263956c6832426e0cadc996ecdb35ddd1705a1a1876c8fc6fa51f9e09ba47a0ec68230157fb23fb0a19ef11dcf6e4837344bab950979800
-EBUILD baca-0.1.16-r1.ebuild 758 BLAKE2B de894a9ce651ba9563ec8357f01a281c1d4fc2c54ae55420755beeb16cb8ce69b10ed5a94c825c0707b58adee6b2695e4bb5fba1f543c44757d808aafc9ec8aa SHA512 002cc55a231bf57184adfdeb2eaa5ff42929825f13df61ccd35ed00f854f636c0d0e38b115e675c4b7775a02c2c79b4fe07518bafcef3ecc35c7854ebcb3e07a
 EBUILD baca-0.1.16-r2.ebuild 754 BLAKE2B 755b57c8a8e67d333ad4151ee22de94c886a80d8f3fe047a3716be3283589d86cbd332e33314b932f391350b01010508e8c9a28b76dbb504f7e486399d40b258 SHA512 c22f8186ac2ec65ae6781c458cc4f7081ce68ab182b04afb40189e14fd5825a67123cb7d457a601f9f0fb282c28f0a9f3f53718356b388e4d6b84ead637e065a
 EBUILD baca-0.1.16-r3.ebuild 1006 BLAKE2B 00e781acbf6037be15f340c330cb4eda2e56667846a19e0db95ea375d215e3822644151d4f905c946a7b1d44a70b557683c3b38a5c26e288cfdffcfbbb5247c3 SHA512 44d9dcb650ff041498ab61c67a03315db3fc48ad66fcf6c0f376da1d808827460ad2f7e443f8af178c39918c278d2e19459a8eaa6b8959888bf1943fb30fa17d
+EBUILD baca-0.1.16-r4.ebuild 1052 BLAKE2B 69f7a37cdc0b75ed5f3f863a87880584cc45be3d609bf4ffb5e537be5b21ae15e023736cc7c165d1c9bed8d65eb1deefd8baf1d6461b8495096ab6bd0c1ce28a SHA512 9c21222517dfc4a437087e02e64714561b9eddc943242ccc677ecdf77edc499df36fd46e3ceeee560db02745d026f7483bca104fcfa5e4c93bce8595bf3e7712
 EBUILD baca-9999.ebuild 752 BLAKE2B 323ae5b77280b53552c0cfba90894eab631f4a208b3e6014402d8812c47734944add0df86a02f1881644f89e2fb1466d1427cab1f64bf681f95c84ca4101bfe8 SHA512 f557391cd1052150562eb44f0c2937aa842725d03fedb3d9d9d99f23059cdab95347aaf78537701fcec2a4743efb783990d092c30bf45d6846c88970feabc44a

+ 49 - 0
app-text/baca/baca-0.1.16-r4.ebuild

@@ -0,0 +1,49 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="A TUI Ebook Reader"
+HOMEPAGE="https://github.com/wustho/baca"
+
+if [[ "${PV}" == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/wustho/baca"
+	#will remove this when baca will bump the tag/version name
+else
+	SRC_URI="https://github.com/wustho/baca/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="${DEPEND}
+	>=dev-python/beautifulsoup4-4.12.0
+	dev-python/rich
+	>=dev-python/textual-0.16.0
+	>=dev-python/appdirs-1.4.4
+	>=dev-python/python-markdownify-0.11.6
+	>=dev-python/peewee-3.16.0
+	>=dev-python/fuzzywuzzy-0.18.0
+	>=dev-python/climage-0.2.0
+	"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=( README.md LICENSE )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+	eapply "${FILESDIR}"/baca-0.1.16_with_CLImage-0.2.0.patch
+	eapply_user
+}
+
+src_install() {
+	distutils-r1_src_install
+}

+ 22 - 0
app-text/baca/files/baca-0.1.16_with_CLImage-0.2.0.patch

@@ -0,0 +1,22 @@
+--- a/src/baca/components/contents.py	2023-06-08 11:46:28.000000000 +0200
++++ b/src/baca/components/contents.py	2023-12-14 15:31:01.693092213 +0100
+@@ -89,7 +89,7 @@
+             # NOTE: -1 for precaution on rounding of screen width
+             oWidth=self.size.width - 1,
+             is_unicode=True,
+-            color_type=climage._color_types.truecolor,
++            color_type=climage.color_types.truecolor,
+             palette="default",
+         )
+         img.close()
+--- a/pyproject.toml	2023-06-08 11:46:28.000000000 +0200
++++ b/pyproject.toml	2023-12-14 15:31:01.693092213 +0100
+@@ -20,7 +20,7 @@
+ appdirs = "^1.4.4"
+ peewee = "^3.16.0"
+ fuzzywuzzy = "^0.18.0"
+-climage = "^0.1.3"
++climage = "^0.2.0"
+ 
+ [tool.poetry.group.dev.dependencies]
+ black = "^23.1.0"

+ 3 - 0
profiles/package.mask

@@ -0,0 +1,3 @@
+# Jean-Christophe Bach <jc.bach@imt-atlantique.fr> (2023-12-14)
+# live ebuild
+>=app-text/baca-9999