Parcourir la source

add bob(-bin) ebuild

jcb il y a 5 mois
Parent
commit
cdb3ae1c83
3 fichiers modifiés avec 37 ajouts et 0 suppressions
  1. 1 0
      README.md
  2. 2 0
      net-p2p/bob-bin/Manifest
  3. 34 0
      net-p2p/bob-bin/bob-bin-9999.ebuild

+ 1 - 0
README.md

@@ -20,6 +20,7 @@ Package list:
 * media-libs/libtxc_dxtn        - [1.0.1]            -- Implementation of the S3 Texture Compression
 * net-misc/ddgr                 - [2.1]              -- A command line utility to search DuckDuckGo from the terminal
 * net-misc/tuir                 - [1.29.0-r1]        -- A terminal user interface (TUI) for Reddit
+* net-p2p/bob-bin               - [9999]             -- B·o·B, an universal & secure peer-to-peer file-transfer (binary version)
 * sys-process/btop              - [1.2.8]            -- A complete monitor of machine resources
 * x11-misc/find-cursor          - [1.8]              -- Simple XLib program to highlight the cursor position
 * x11-plugins/purple-discord    - [9999]             -- A libpurple/Pidgin plugin for Discord

+ 2 - 0
net-p2p/bob-bin/Manifest

@@ -0,0 +1,2 @@
+DIST bob 7110656 BLAKE2B 9e922a1e4ce756f7b61baa487b37e5c806ead1145385e2807c97b28654691c95f4b915bbe5bf7283a2c77dd79675b76ac038c5ff27d54b1bfea75c8539066f87 SHA512 2f424663b6db35ecd4472ef3795fe75e80353b28c00fa5b37ebceabf7cde423ce8bc88320a94cc167387a05f1020d38254e859ffacc7d893359c90cca1d0d5f6
+EBUILD bob-bin-9999.ebuild 696 BLAKE2B d1572c7fcb0737a426d9fa2989b6b0c610b94ffc3d30cf98683714f633ee2fd8a642844261799631837e71138de02078b58a67aa80b54f94786c7c14b8152cfa SHA512 27c36e3960c65bf6187d1bb1d3dc9d4da75311574f597fae5befdbb2b3aa5c9174c755afcb944e8fadf4d7a430fe3a640f8b7cf1756c51ca59698320424dc630

+ 34 - 0
net-p2p/bob-bin/bob-bin-9999.ebuild

@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+UPSTREAM_PN="bob.com"
+MY_PN="bob"
+S=${WORKDIR}/
+
+DESCRIPTION="B·o·B, an universal & secure peer-to-peer file-transfer (binary version)"
+HOMEPAGE="
+	https://bob.osau.re/
+	https://github.com/dinosaure/bob
+"
+SRC_URI="https://builds.osau.re/job/bob/build/latest/f/bin/${UPSTREAM_PN} -> ${MY_PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+	exeinto /usr/bin
+	newexe ${DISTDIR}/"${MY_PN}" "${MY_PN}"
+}
+
+pkg_postinst() {
+	einfo "Turn bob.com into a truly native program (assimilation)"
+	su -s /bin/sh -c "/usr/bin/bob --assimilate"
+}
+