Parcourir la source

pyexcel-ezodf: fix ebuild (update Python compat)

jcb il y a 4 mois
Parent
commit
d8f32ed8fa

+ 1 - 1
README.md

@@ -18,7 +18,7 @@ Package list:
 * dev-python/kitchen            - [1.2.6-r2]         -- Useful snippets of code that everybody ends up writing for their projects
 * dev-python/papis-python-rofi  - [1.0.2]            -- Python module to create simple GUIs with Rofi (fork for papis)
 * dev-python/papis-rofi         - [0.2.0-r1]         -- Papis GUI using Rofi
-* dev-python/pyexcel-ezodf      - [0.3.4-r1]         -- Library to manipulate OpenDocument files (pyexcel version)
+* dev-python/pyexcel-ezodf      - [0.3.4-r2]         -- Library to manipulate OpenDocument files (pyexcel version)
 * dev-python/pykdtree           - [1.3.11]           -- Fast kd-tree implementation with OpenMP-enabled queries
 * dev-python/python-doi         - [0.2]              -- Python package to work with Document Object Identifier (doi)
 * dev-python/python-markdownify - [0.12.1]           -- Library to convert HTML to Markdown 

+ 1 - 0
dev-python/pyexcel-ezodf/Manifest

@@ -1,2 +1,3 @@
 DIST pyexcel-ezodf-0.3.4.tar.gz 3945925 BLAKE2B 54e3d8adf419bd7fefe0187873742315467c870fe75dfb8b86ff44601005ad4bb3c8acd524f3609841598b4bdbcb9dd82826c6e584be76fc0651e0a30ac8feff SHA512 c77dd1ed13213bbb9a5b6f69e4ca6bac11fbbed5da41f4b4540196c72728940b3d2a83c904dbb65aaeca6f8fc88217bc67ba14183b31fb04b5204a0de5648e4b
 EBUILD pyexcel-ezodf-0.3.4-r1.ebuild 609 BLAKE2B 1cbe8ca227b79f7538599334a6954eef1b3c06c3e49b29c3dccac9809cbda5507e7166ae0ef31a89a660f24640f28adc3f36a6e9298ee12bbfabde3b8315c2c7 SHA512 1f748c658dcbecea1af71cdd741d1945f3f37340643f34f96168336c0d203b431c0c18452b084ec2993b42fab3692c6091a71ed21f68bff1f4e984b7f6cc2d4d
+EBUILD pyexcel-ezodf-0.3.4-r2.ebuild 615 BLAKE2B 7096930c1230008960e63e23d7658a526feb9352788da461de7aa97004e9c68a3f02bc58b58445f2016d9379a5b7412adab84b7a72125e2bd0872adfda26cc3c SHA512 cf8e72e0c50a0e207b6e4104054c92ea61097459a7378e54c721c2e2e67c898a017dc48745418692ad9fc666a8ce17cc54e8c30b8d0a26f3c587e4c7278447d5

+ 28 - 0
dev-python/pyexcel-ezodf/pyexcel-ezodf-0.3.4-r2.ebuild

@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13})
+inherit distutils-r1
+
+DESCRIPTION="Library to manipulate OpenDocument files (pyexcel version)"
+HOMEPAGE="https://github.com/pyexcel/pyexcel-ezodf"
+SRC_URI="https://github.com/pyexcel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-python/lxml"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=( README.rst CHANGELOG.rst CONTRIBUTORS.rst docs/ )
+
+
+distutils_enable_tests setup.py
+
+src_install() {
+	distutils-r1_src_install
+}