Explorar el Código

add (temporarily) app-vim/vim-latex-1.10.0-r3, until the official package is updated

jcb hace 11 meses
padre
commit
e195109dd8
Se han modificado 3 ficheros con 65 adiciones y 0 borrados
  1. 1 0
      README.md
  2. 2 0
      app-vim/vim-latex/Manifest
  3. 62 0
      app-vim/vim-latex/vim-latex-1.10.0-r3.ebuild

+ 1 - 0
README.md

@@ -7,6 +7,7 @@ Package list:
 * app-text/ods2md               - [9999]       -- Convert LibreOffice Spreadsheets (*.ods) into Markdown tables
 * app-text/gpp                  - [2.27]       -- Command-line tool for looking up colors, shades and palettes
 * app-text/zaread               - [9999]       -- A (very) lightweight MS Office files reader
+* app-vim/vim-latex             - [1.10.0-r3]  -- A comprehensive set of tools to view, edit and compile LaTeX documents [temporary ebuild, until the official one is updated]
 * dev-python/pyexcel-ezodf      - [0.3.4-r1]   -- Library to manipulate OpenDocument files (pyexcel version)
 * dev-python/python-markdownify - [0.11.6]     -- Library to convert HTML to Markdown 
 * dev-python/fire               - [0.5.0]      -- Library for automatically generating CLIs with a single line of code

+ 2 - 0
app-vim/vim-latex/Manifest

@@ -0,0 +1,2 @@
+DIST vim-latex-1.10.0.tar.gz 260820 BLAKE2B 2314ad5ded3bea51def3172e8f2b7a7483839b58804f9d8c1cc1c8f1139c1da731f91525691d47dba57d07a7db85c371e87c5ce0d3d22a004a9402df7e7cad3a SHA512 1d22b675c124e402a280dcc3a675b49a92fb9f4d42efdda0ea97be26379cd6c023589a35e165f4231524d853380e22411901bfbcc98f171c938ba800821a1213
+EBUILD vim-latex-1.10.0-r3.ebuild 1489 BLAKE2B b50533f4f6709eecd43b0b71639c58acb7d919c18d04f5f39b29e02f0e0b3771ea383460e8a3c5327dda969c2dd1bd77a6c48cf8cf1b6d576923f09e274e0935 SHA512 bdf260ddf27103f699b88e344d86f434828774a05bc8774762910e6e6967b0b0c122f6c608f93f14b4ececa07980910db67a1d15aea9b64cc48d2df3fd34a0d2

+ 62 - 0
app-vim/vim-latex/vim-latex-1.10.0-r3.ebuild

@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="A comprehensive set of tools to view, edit and compile LaTeX documents"
+HOMEPAGE="http://vim-latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+	${PYTHON_DEPS}
+	|| (
+		app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+		app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+	)
+	virtual/latex-base
+	!app-vim/vimtex"
+
+VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
+
+src_compile() { :; }
+
+src_install() {
+	# don't mess up vim's doc dir with random files
+	mv doc mydoc || die
+	mkdir doc || die
+	mv mydoc/*.txt doc/ || die
+	rm -rf mydoc || die
+
+	# don't install buggy tags scripts, use ctags instead
+	rm latextags ltags || die
+
+	vim-plugin_src_install
+
+	# use executable permissions (bug #352403)
+	fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py
+
+	python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+	vim-plugin_pkg_postinst
+
+	if [[ -z ${REPLACING_VERSIONS} ]]; then
+		echo
+		elog "To use the vim-latex plugin add:"
+		elog "   filetype plugin on"
+		elog '   set grepprg=grep\ -nH\ $*'
+		elog "   let g:tex_flavor='latex'"
+		elog "to your ~/.vimrc-file"
+		echo
+	fi
+}