Explorar el Código

bump version: vim-latex-1.10.0-r4 (temporary ebuild)

jcb hace 4 meses
padre
commit
ebf906e46f
Se han modificado 3 ficheros con 64 adiciones y 1 borrados
  1. 1 1
      README.md
  2. 1 0
      app-vim/vim-latex/Manifest
  3. 62 0
      app-vim/vim-latex/vim-latex-1.10.0-r4.ebuild

+ 1 - 1
README.md

@@ -9,7 +9,7 @@ Package list:
 * app-text/ods2md               - [9999-r2]          -- Convert LibreOffice Spreadsheets (*.ods) into Markdown tables
 * app-text/papis                - [0.13-r1]          -- A powerful and highly extensible CLI document and bibliography manager
 * app-text/zaread               - [9999]             -- A (very) lightweight MS Office files reader
-* app-vim/vim-latex             - [1.10.0-r3]        -- A comprehensive set of tools to view, edit and compile LaTeX documents [temporary ebuild, until the official one is updated]
+* app-vim/vim-latex             - [1.10.0-r4]        -- A comprehensive set of tools to view, edit and compile LaTeX documents [temporary ebuild, until the official one is updated]
 * dev-python/arxiv2bib          - [1.0.8]            -- CLI tool to get metadata for academic papers arXiv.org in BibTeX format
 * dev-python/climage            - [0.2.0-r2]         -- Tool that converts images to beautiful ANSI escape codes for display in CLI
 * dev-python/fire               - [0.5.0]            -- Library for automatically generating CLIs with a single line of code

+ 1 - 0
app-vim/vim-latex/Manifest

@@ -1,2 +1,3 @@
 DIST vim-latex-1.10.0.tar.gz 260820 BLAKE2B 2314ad5ded3bea51def3172e8f2b7a7483839b58804f9d8c1cc1c8f1139c1da731f91525691d47dba57d07a7db85c371e87c5ce0d3d22a004a9402df7e7cad3a SHA512 1d22b675c124e402a280dcc3a675b49a92fb9f4d42efdda0ea97be26379cd6c023589a35e165f4231524d853380e22411901bfbcc98f171c938ba800821a1213
 EBUILD vim-latex-1.10.0-r3.ebuild 1489 BLAKE2B b50533f4f6709eecd43b0b71639c58acb7d919c18d04f5f39b29e02f0e0b3771ea383460e8a3c5327dda969c2dd1bd77a6c48cf8cf1b6d576923f09e274e0935 SHA512 bdf260ddf27103f699b88e344d86f434828774a05bc8774762910e6e6967b0b0c122f6c608f93f14b4ececa07980910db67a1d15aea9b64cc48d2df3fd34a0d2
+EBUILD vim-latex-1.10.0-r4.ebuild 1489 BLAKE2B 111c7bf7ffebcfe60fd23c1c6feaeb6aa4db5ff2d063ca96de0b3fbb333aba30cb1ea87425ad2899708041c2dc0935956072f7e11c23d634cc6e0ad072ae3bd5 SHA512 b12c34f7ee4e2c408eeac3118a82027b78eafab2c08059c86338d1276bc345e543db72cc4c963b217842747ae5a6c24d9e2b1ae94fd73f00357f183a1f7a9a96

+ 62 - 0
app-vim/vim-latex/vim-latex-1.10.0-r4.ebuild

@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..13} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="A comprehensive set of tools to view, edit and compile LaTeX documents"
+HOMEPAGE="http://vim-latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+	${PYTHON_DEPS}
+	|| (
+		app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+		app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+	)
+	virtual/latex-base
+	!app-vim/vimtex"
+
+VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
+
+src_compile() { :; }
+
+src_install() {
+	# don't mess up vim's doc dir with random files
+	mv doc mydoc || die
+	mkdir doc || die
+	mv mydoc/*.txt doc/ || die
+	rm -rf mydoc || die
+
+	# don't install buggy tags scripts, use ctags instead
+	rm latextags ltags || die
+
+	vim-plugin_src_install
+
+	# use executable permissions (bug #352403)
+	fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py
+
+	python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+	vim-plugin_pkg_postinst
+
+	if [[ -z ${REPLACING_VERSIONS} ]]; then
+		echo
+		elog "To use the vim-latex plugin add:"
+		elog "   filetype plugin on"
+		elog '   set grepprg=grep\ -nH\ $*'
+		elog "   let g:tex_flavor='latex'"
+		elog "to your ~/.vimrc-file"
+		echo
+	fi
+}