Browse Source

add media-fonts/square ebuild

jcb 1 year ago
parent
commit
ff5cab03d2
3 changed files with 27 additions and 1 deletions
  1. 2 1
      README.md
  2. 2 0
      media-fonts/square/Manifest
  3. 23 0
      media-fonts/square/square-1.0.ebuild

+ 2 - 1
README.md

@@ -1,4 +1,4 @@
-slash's personal overlay
+EADME.md
 
 Package list:
 * app-text/colorpedia        - [1.2.3]  -- General-purpose preprocessor with customizable syntax
@@ -8,6 +8,7 @@ Package list:
 * dev-python/pyexcel-ezodf   - [0.3.4]  -- Library to manipulate OpenDocument files (pyexcel version)
 * dev-python/fire            - [0.4.0]  -- Library for automatically generating CLIs with a single line of code
 * dev-python/kitchen         - [1.2.5]  -- Useful snippets of code that everybody ends up writing for their projects
+* media-fonts/square         - [1.0]    -- A TTF font designed to make characters fill a square space
 * media-libs/libtxc_dxtn     - [1.0.1]  -- Implementation of the S3 Texture Compression
 * net-misc/ddgr              - [1.9]    -- A command line utility to search DuckDuckGo from the terminal
 * net-misc/tuir              - [1.29.0] -- A terminal user interface (TUI) for Reddit

+ 2 - 0
media-fonts/square/Manifest

@@ -0,0 +1,2 @@
+DIST square.ttf 8532 BLAKE2B b6ce1702e46b1270477344d5f37a384c64f2336ff941871f0f1af93fb53c6a893332df2397a04d5687c36c1de6e60d7f30d38f39267debbadd56cebc5152d43d SHA512 2dfffb95ccebd353116a634baff2ba400ccdc4d04bbfabaf989eea2336f986f0364e8c708eed38c433951af7d6a2454b7b12d170122aba3ee4ab7f4df409cab4
+EBUILD square-1.0.ebuild 552 BLAKE2B 7ed99d2d5341797a637dafbee25fb6c46805f3e7d5b4281e8efad940ec1d22da02abcf1afc812997a80fe7a79d2d2df172a3e79fc3fc7d488f538f9413807be3 SHA512 c549792a70eb279583306831a434d5c9b55ed4968b38c0d813ebb6ec2dd82f092cf707519b41966a68221ce32310beae4907b58fee909ae10b043ac3b33d955d

+ 23 - 0
media-fonts/square/square-1.0.ebuild

@@ -0,0 +1,23 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit font
+
+DESCRIPTION="A TTF font designed to make characters fill a square space."
+HOMEPAGE="https://strlen.com/square/"
+SRC_URI="https://strlen.com/files/square.ttf"
+
+LICENSE="CC-BY-3.0" #Creative Commons Attribution 3.0 Unported licence
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+FONT_SUFFIX="ttf"
+
+src_install() {
+	mkdir -p ${D}/usr/share/fonts/square/
+	cp ${DISTDIR}/${PN}.ttf ${D}/usr/share/fonts/square/${PN}.ttf
+}