tuir-1.29.0.ebuild 726 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python{3_7,3_8,3_9,3_10} )
  5. PYTHON_REQ_USE="ncurses"
  6. inherit distutils-r1
  7. DESCRIPTION="A terminal user interface (TUI) for Reddit"
  8. HOMEPAGE="https://gitlab.com/ajak/tuir"
  9. SRC_URI="https://gitlab.com/ajak/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
  10. LICENSE="MIT"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. S="${WORKDIR}/${PN}-v${PV}"
  14. RDEPEND="
  15. dev-python/beautifulsoup4[${PYTHON_USEDEP}]
  16. dev-python/decorator[${PYTHON_USEDEP}]
  17. dev-python/kitchen[${PYTHON_USEDEP}]
  18. dev-python/requests[${PYTHON_USEDEP}]
  19. dev-python/six[${PYTHON_USEDEP}]
  20. "
  21. BDEPEND="test? ( dev-python/vcrpy )"
  22. distutils_enable_tests pytest