load-time-9999.ebuild 575 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="Program that mesures the time it takes to load a shared library"
  6. HOMEPAGE="https://github.com/serge-sans-paille/load-time"
  7. EGIT_REPO_URI="https://github.com/serge-sans-paille/${PN}"
  8. LICENSE="BSD-3-Clause"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. DEPEND=""
  12. RDEPEND="${DEPEND}"
  13. BDEPEND="sys-devel/gcc"
  14. DOCS=( README.rst LICENSE )
  15. src_prepare() {
  16. default
  17. }
  18. src_compile() {
  19. emake
  20. }
  21. src_install() {
  22. exeinto "/usr/bin"
  23. doexe ${PN}
  24. dodoc ${DOCS}
  25. }