baca-0.1.16-r3.ebuild 1006 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=poetry
  5. PYTHON_COMPAT=( python3_{10..12} )
  6. inherit distutils-r1
  7. DESCRIPTION="A TUI Ebook Reader"
  8. HOMEPAGE="https://github.com/wustho/baca"
  9. if [[ "${PV}" == *9999 ]]; then
  10. inherit git-r3
  11. EGIT_REPO_URI="https://github.com/wustho/baca"
  12. #will remove this when baca will bump the tag/version name
  13. DEPEND=">=dev-python/climage-0.2.0"
  14. else
  15. SRC_URI="https://github.com/wustho/baca/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  16. DEPEND="<dev-python/climage-0.2.0"
  17. fi
  18. LICENSE="GPL-3"
  19. SLOT="0"
  20. KEYWORDS="~amd64"
  21. DEPEND="${DEPEND}
  22. >=dev-python/beautifulsoup4-4.12.0
  23. dev-python/rich
  24. >=dev-python/textual-0.16.0
  25. >=dev-python/appdirs-1.4.4
  26. >=dev-python/python-markdownify-0.11.6
  27. >=dev-python/peewee-3.16.0
  28. >=dev-python/fuzzywuzzy-0.18.0
  29. "
  30. RDEPEND="${DEPEND}"
  31. BDEPEND=""
  32. DOCS=( README.md LICENSE )
  33. distutils_enable_tests pytest
  34. src_install() {
  35. distutils-r1_src_install
  36. }