baca-0.1.17.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=poetry
  5. PYTHON_COMPAT=( python3_{10..13} )
  6. inherit distutils-r1
  7. DESCRIPTION="A TUI Ebook Reader"
  8. HOMEPAGE="https://github.com/wustho/baca"
  9. if [[ "${PV}" == *9999 ]]; then
  10. inherit git-r3
  11. EGIT_REPO_URI="https://github.com/wustho/baca"
  12. #will remove this when baca will bump the tag/version name
  13. else
  14. SRC_URI="https://github.com/wustho/baca/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  15. fi
  16. LICENSE="GPL-3"
  17. SLOT="0"
  18. KEYWORDS="~amd64"
  19. DEPEND="${DEPEND}
  20. >=dev-python/beautifulsoup4-4.12.0
  21. dev-python/rich
  22. >=dev-python/textual-0.16.0
  23. >=dev-python/appdirs-1.4.4
  24. >=dev-python/python-markdownify-0.11.6
  25. >=dev-python/peewee-3.16.0
  26. >=dev-python/fuzzywuzzy-0.18.0
  27. >=dev-python/climage-0.2.0
  28. "
  29. RDEPEND="${DEPEND}"
  30. BDEPEND=""
  31. DOCS=( README.md LICENSE )
  32. distutils_enable_tests pytest
  33. #src_prepare() {
  34. # eapply "${FILESDIR}"/baca-0.1.16_with_CLImage-0.2.0.patch
  35. # eapply_user
  36. #}
  37. src_install() {
  38. distutils-r1_src_install
  39. }