baca-9999.ebuild 752 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=poetry
  5. PYTHON_COMPAT=( python3_{10..13} )
  6. inherit distutils-r1 git-r3
  7. DESCRIPTION="A TUI Ebook Reader"
  8. HOMEPAGE="https://github.com/wustho/baca"
  9. EGIT_REPO_URI="https://github.com/wustho/baca"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~amd64"
  13. DEPEND="
  14. >=dev-python/beautifulsoup4-4.12.0
  15. dev-python/rich
  16. >=dev-python/textual-0.16.0
  17. >=dev-python/appdirs-1.4.4
  18. >=dev-python/python-markdownify-0.11.6
  19. >=dev-python/peewee-3.16.0
  20. >=dev-python/fuzzywuzzy-0.18.0
  21. >=dev-python/climage-0.2.0
  22. "
  23. RDEPEND="${DEPEND}"
  24. BDEPEND=""
  25. DOCS=( README.md LICENSE )
  26. distutils_enable_tests pytest
  27. src_install() {
  28. distutils-r1_src_install
  29. }