colorpedia-1.2.3-r4.ebuild 996 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{10,11,12,13} )
  5. DISTUTILS_USE_SETUPTOOLS=rdepend
  6. inherit distutils-r1 pypi
  7. DESCRIPTION="Command-line tool for looking up colors, shades and palettes"
  8. HOMEPAGE="https://github.com/joowani/colorpedia"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. if [[ "${PV}" == *9999 ]]; then
  13. inherit git-r3
  14. EGIT_REPO_URI="https://github.com/joowani/colorpedia"
  15. else
  16. SRC_URI="$(pypi_sdist_url "${PN^}" "${PV}")"
  17. fi
  18. RDEPEND="
  19. dev-python/six[${PYTHON_USEDEP}]
  20. dev-python/packaging[${PYTHON_USEDEP}]
  21. dev-python/tomli[${PYTHON_USEDEP}]
  22. dev-python/pyparsing[${PYTHON_USEDEP}]
  23. dev-python/fire[${PYTHON_USEDEP}]
  24. dev-python/termcolor[${PYTHON_USEDEP}]"
  25. BDEPEND="
  26. dev-python/setuptools[${PYTHON_USEDEP}]
  27. dev-python/setuptools-scm[${PYTHON_USEDEP}]"
  28. DOCS=( docs/README.md docs/CONTRIBUTING.md )
  29. #distutils_enable_tests setup.py
  30. src_install() {
  31. distutils-r1_src_install
  32. }