csv2ical-9999.ebuild 633 B

12345678910111213141516171819202122232425262728
  1. # Copyright 2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{7,8,9,10,11,12} )
  5. DISTUTILS_USE_PEP517=no
  6. inherit git-r3 distutils-r1
  7. DESCRIPTION="Converts a CSV file with event information to an iCalendar ICS file"
  8. HOMEPAGE="https://github.com/rlan/csv2ical"
  9. EGIT_REPO_URI="https://github.com/rlan/${PN}"
  10. LICENSE="MIT"
  11. SLOT="0"
  12. KEYWORDS="~amd64"
  13. DEPEND=">=dev-python/icalendar-4.0.1[${PYTHON_USEDEP}]"
  14. RDEPEND="${DEPEND}"
  15. BDEPEND=""
  16. DOCS=( README.md LICENSE sample.csv sample.ics )
  17. src_install() {
  18. exeinto "/usr/bin"
  19. newexe ${PN}.py ${PN}
  20. dodoc ${DOCS}
  21. }