gpp-2.27.ebuild 550 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit autotools
  5. DESCRIPTION="General-purpose preprocessor with customizable syntax"
  6. HOMEPAGE="https://logological.org/gpp"
  7. SRC_URI="https://github.com/logological/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="LGPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. DEPEND=""
  12. RDEPEND="${DEPEND}"
  13. BDEPEND=""
  14. src_prepare() {
  15. eapply_user
  16. eautoreconf
  17. }
  18. src_configure() {
  19. econf
  20. }
  21. src_install() {
  22. default
  23. emake DESTDIR="${D}" install
  24. }