papis-0.13.ebuild 2.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. # Copyright 2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=setuptools
  5. PYTHON_COMPAT=( python3_{10..12} )
  6. inherit bash-completion-r1 distutils-r1
  7. DESCRIPTION="A powerful and highly extensible CLI document and bibliography manager"
  8. HOMEPAGE="https://github.com/papis/papis/ https://pypi.org/project/papis/"
  9. SRC_URI="https://github.com/papis/papis/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~amd64"
  13. IUSE="bash-completion zsh-completion fish-completion"
  14. RDEPEND="
  15. >=dev-python/pyaml-3.12[${PYTHON_USEDEP}]
  16. >=dev-python/arxiv2bib-1.0.0[${PYTHON_USEDEP}]
  17. >=dev-python/beautifulsoup4-4.4.1[${PYTHON_USEDEP}]
  18. >=dev-python/bibtexparser-1.4[${PYTHON_USEDEP}]
  19. <dev-python/bibtexparser-2[${PYTHON_USEDEP}]
  20. >=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]
  21. >=dev-python/click-7.0.0[${PYTHON_USEDEP}]
  22. >=dev-python/colorama-0.2[${PYTHON_USEDEP}]
  23. dev-python/dominate[${PYTHON_USEDEP}]
  24. >=dev-python/filetype-1.0.1[${PYTHON_USEDEP}]
  25. >=dev-python/habanero-0.6.0[${PYTHON_USEDEP}]
  26. >=dev-python/isbnlib-3.9.1[${PYTHON_USEDEP}]
  27. >=dev-python/lxml-4.3.5[${PYTHON_USEDEP}]
  28. >=dev-python/prompt-toolkit-3.0.0[${PYTHON_USEDEP}]
  29. >=dev-python/pygments-2.2.0[${PYTHON_USEDEP}]
  30. >=dev-python/pyparsing-2.2.0[${PYTHON_USEDEP}]
  31. >=dev-python/python-doi-0.1.1[${PYTHON_USEDEP}]
  32. >=dev-python/python-slugify-1.2.6[${PYTHON_USEDEP}]
  33. >=dev-python/requests-2.11.1[${PYTHON_USEDEP}]
  34. >=dev-python/stevedore-1.30[${PYTHON_USEDEP}]
  35. >=dev-python/tqdm-4.1[${PYTHON_USEDEP}]
  36. >=dev-python/typing-extensions-3.7[${PYTHON_USEDEP}]
  37. "
  38. DOCS=( AUTHORS CONTRIBUTING.md CHANGELOG.md CODE_OF_CONDUCT.md HACKING.md INSTALL LICENSE doc/ )
  39. distutils_enable_tests pytest
  40. src_install() {
  41. distutils-r1_src_install
  42. dodoc -r ${DOCS}
  43. if use bash-completion
  44. then
  45. newbashcomp scripts/shell_completion/click/bash/${PN}.bash ${PN}
  46. fi
  47. if use zsh-completion
  48. then
  49. insinto /usr/share/zsh/site-functions/
  50. newins scripts/shell_completion/click/_${PN} _${PN}
  51. fi
  52. if use fish-completion
  53. then
  54. insinto /usr/share/fish/vendor_completions.d/
  55. newins scripts/shell_completion/click/fish/${PN}.fish ${PN}.fish
  56. fi
  57. }
  58. #should disappear when the ebuild will be fixed
  59. pkg_postinst() {
  60. #why does it create /usr/share/doc/papis/ in addition to /usr/share/doc/papis-0.13/?
  61. rm -r /usr/share/doc/papis/
  62. }