zaread-9999.ebuild 544 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="A (very) lightweight MS Office files reader"
  6. HOMEPAGE="https://github.com/paoloap/zaread"
  7. EGIT_REPO_URI="https://github.com/paoloap/${PN}"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="zathura"
  12. #libreoffice + optionally zathura
  13. DEPEND="
  14. virtual/ooo
  15. zathura? ( app-text/zathura )
  16. "
  17. RDEPEND="${DEPEND}"
  18. BDEPEND=""
  19. DOCS=( README.md )
  20. src_install() {
  21. exeinto "/usr/bin"
  22. doexe ${PN}
  23. #dodoc ${DOCS}
  24. }