vim-latex-1.10.0-r4.ebuild 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{9..13} )
  5. inherit vim-plugin python-single-r1
  6. DESCRIPTION="A comprehensive set of tools to view, edit and compile LaTeX documents"
  7. HOMEPAGE="http://vim-latex.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  9. LICENSE="vim"
  10. KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
  11. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  12. RDEPEND="
  13. ${PYTHON_DEPS}
  14. || (
  15. app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
  16. app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
  17. )
  18. virtual/latex-base
  19. !app-vim/vimtex"
  20. VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
  21. src_compile() { :; }
  22. src_install() {
  23. # don't mess up vim's doc dir with random files
  24. mv doc mydoc || die
  25. mkdir doc || die
  26. mv mydoc/*.txt doc/ || die
  27. rm -rf mydoc || die
  28. # don't install buggy tags scripts, use ctags instead
  29. rm latextags ltags || die
  30. vim-plugin_src_install
  31. # use executable permissions (bug #352403)
  32. fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py
  33. python_fix_shebang "${ED}"
  34. }
  35. pkg_postinst() {
  36. vim-plugin_pkg_postinst
  37. if [[ -z ${REPLACING_VERSIONS} ]]; then
  38. echo
  39. elog "To use the vim-latex plugin add:"
  40. elog " filetype plugin on"
  41. elog ' set grepprg=grep\ -nH\ $*'
  42. elog " let g:tex_flavor='latex'"
  43. elog "to your ~/.vimrc-file"
  44. echo
  45. fi
  46. }