arxiv2bib-1.0.8.ebuild 609 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=setuptools
  5. PYTHON_COMPAT=( python3_{10..12} )
  6. inherit distutils-r1
  7. DESCRIPTION="CLI tool to get metadata for academic papers arXiv.org in BibTeX format"
  8. HOMEPAGE="https://nathangrigg.github.io/arxiv2bib"
  9. SRC_URI="https://github.com/nathangrigg/arxiv2bib/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. KEYWORDS="~amd64"
  13. RDEPEND=""
  14. BDEPEND=""
  15. DOCS=( README.rst HISTORY.txt )
  16. distutils_enable_tests setup.py
  17. src_install() {
  18. distutils-r1_src_install
  19. }