climage-0.1.3-r2.ebuild 822 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=setuptools
  5. PYTHON_COMPAT=( python3_{10..11} )
  6. inherit distutils-r1 pypi
  7. MY_PN=CLImage
  8. MY_P=${MY_PN}-${PV}
  9. S=${WORKDIR}/${MY_P}
  10. DESCRIPTION="Tool that converts images to beautiful ANSI escape codes for display in CLI"
  11. HOMEPAGE="
  12. https://github.com/pnappa/CLImage
  13. https://pypi.org/project/climage/
  14. "
  15. SRC_URI="https://github.com/pnappa/CLImage/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.tar.gz"
  16. LICENSE="GPL-3"
  17. SLOT="0"
  18. KEYWORDS="~amd64"
  19. RDEPEND="
  20. dev-python/pillow
  21. dev-python/pykdtree
  22. "
  23. BDEPEND=""
  24. DOCS=( README.md LICENSE )
  25. distutils_enable_tests pytest
  26. src_prepare() {
  27. eapply "${FILESDIR}"/${P}-climage.py-import.patch
  28. eapply_user
  29. }
  30. src_install() {
  31. distutils-r1_src_install
  32. }