fire-0.4.0-r1.ebuild 663 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{6,7,8,9,10,11} )
  5. inherit distutils-r1
  6. DESCRIPTION="Library for automatically generating CLIs with a single line of code"
  7. HOMEPAGE="https://github.com/google/python-fire"
  8. LICENSE="Apache-2.0"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. if [[ "${PV}" == *9999 ]]; then
  12. inherit git-r3
  13. EGIT_REPO_URI="https://github.com/google/python-fire"
  14. else
  15. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  16. fi
  17. DEPEND=""
  18. RDEPEND="${DEPEND}"
  19. BDEPEND=""
  20. DOCS=( README.md )
  21. distutils_enable_tests setup.py
  22. src_install() {
  23. distutils-r1_src_install
  24. }