fire-0.6.0.ebuild 827 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{10..13} )
  5. inherit distutils-r1
  6. MY_PN=python-${PN}
  7. MY_P=${MY_PN}-${PV}
  8. S=${WORKDIR}/${MY_P}
  9. DESCRIPTION="Library for automatically generating CLIs with a single line of code"
  10. HOMEPAGE="
  11. https://github.com/google/python-fire
  12. https://pypi.org/project/fire/"
  13. if [[ "${PV}" == *9999 ]]; then
  14. inherit git-r3
  15. EGIT_REPO_URI="https://github.com/google/python-fire"
  16. else
  17. SRC_URI="https://github.com/google/python-fire/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.tar.gz"
  18. fi
  19. LICENSE="Apache-2.0"
  20. SLOT="0"
  21. KEYWORDS="~amd64 ~x86"
  22. DEPEND=""
  23. RDEPEND="${DEPEND}"
  24. BDEPEND=""
  25. DOCS=( README.md LICENSE CONTRIBUTING.md docs/ )
  26. distutils_enable_tests setup.py
  27. src_install() {
  28. distutils-r1_src_install
  29. }