habanero-1.2.6.ebuild 631 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=setuptools
  5. PYTHON_COMPAT=( python3_{10..12} )
  6. inherit distutils-r1
  7. DESCRIPTION="Low level client for Crossref search API"
  8. HOMEPAGE="https://github.com/sckott/habanero/https://pypi.org/project/habanero/"
  9. SRC_URI="https://github.com/sckott/habanero/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="MIT"
  11. SLOT="0"
  12. KEYWORDS="~amd64"
  13. RDEPEND="
  14. "
  15. BDEPEND=""
  16. #DOCS=( Changelog.md LICENSE README.rst CODE_OF_CONDUCT.md )
  17. distutils_enable_tests pytest
  18. src_install() {
  19. distutils-r1_src_install
  20. }