isbnlib-3.10.14.ebuild 719 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=setuptools
  5. PYTHON_COMPAT=( python3_{10..12} )
  6. inherit distutils-r1
  7. DESCRIPTION="A library to validate, clean, transform and get metadata for ISBN strings"
  8. HOMEPAGE="https://github.com/xlcnd/isbnlib/ https://pypi.org/project/isbnlib/"
  9. SRC_URI="https://github.com/xlcnd/isbnlib/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="LGPL-3"
  11. SLOT="0"
  12. KEYWORDS="~amd64"
  13. RDEPEND=""
  14. BDEPEND=""
  15. DOCS=( AUTHORS.md CONTRIBUTING.md CHANGES.txt LICENSE-LGPL-3.0.txt release.md SECURITY.md README.rst COPYRIGHT.txt)
  16. distutils_enable_tests setup.py
  17. src_install() {
  18. distutils-r1_src_install
  19. }