kitchen-1.2.6-r2.ebuild 702 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{10..13} )
  5. inherit distutils-r1 pypi
  6. DESCRIPTION="Useful snippets of code that everybody ends up writing for their projects"
  7. HOMEPAGE="https://github.com/fedora-infra/kitchen"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="chardet"
  12. if [[ "${PV}" == *9999 ]]; then
  13. inherit git-r3
  14. EGIT_REPO_URI="https://github.com/fedora-infra/kitchen"
  15. else
  16. SRC_URI="$(pypi_sdist_url "${PN^}" "${PV}")"
  17. fi
  18. DEPEND="
  19. chardet? ( dev-python/chardet )
  20. "
  21. DOCS=( README.rst NEWS.rst HACKING.rst )
  22. distutils_enable_tests setup.py
  23. src_install() {
  24. distutils-r1_src_install
  25. }