papis-python-rofi-1.0.2.ebuild 722 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=setuptools
  5. PYTHON_COMPAT=( python3_{10..12} )
  6. inherit distutils-r1
  7. MY_PN=python-rofi
  8. MY_P=${MY_PN}-${PV}
  9. S=${WORKDIR}/${MY_P}
  10. DESCRIPTION="Python module to create simple GUIs with Rofi (fork for papis)"
  11. HOMEPAGE="https://github.com/papis/python-rofi/ https://pypi.org/project/papis-python-rofi/"
  12. SRC_URI="https://github.com/papis/python-rofi/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  13. LICENSE="MIT"
  14. SLOT="0"
  15. KEYWORDS="~amd64"
  16. DEPEND=""
  17. RDEPEND="${DEPEND}"
  18. BDEPEND=""
  19. DOCS=( README.rst MANIFEST.in LICENSE )
  20. distutils_enable_tests pytest
  21. src_install() {
  22. distutils-r1_src_install
  23. }