papis-rofi-0.2.0.ebuild 711 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=setuptools
  5. PYTHON_COMPAT=( python3_{10..12} )
  6. inherit distutils-r1
  7. DESCRIPTION="Papis GUI using Rofi"
  8. HOMEPAGE="https://github.com/papis/papis-rofi https://pypi.org/project/papis-rofi/"
  9. #Release and tags stopped at 0.2.0 on GitHub (0.6.0 on pypi)
  10. SRC_URI="https://github.com/papis/papis-rofi/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  11. #SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  12. LICENSE="GPL-3"
  13. SLOT="0"
  14. KEYWORDS="~amd64"
  15. DEPEND=""
  16. RDEPEND="${DEPEND}"
  17. BDEPEND=""
  18. DOCS=( README.rst doc/ )
  19. distutils_enable_tests pytest
  20. src_install() {
  21. distutils-r1_src_install
  22. }