pyexcel-ezodf-0.3.4-r2.ebuild 615 B

12345678910111213141516171819202122232425262728
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{10..13})
  5. inherit distutils-r1
  6. DESCRIPTION="Library to manipulate OpenDocument files (pyexcel version)"
  7. HOMEPAGE="https://github.com/pyexcel/pyexcel-ezodf"
  8. SRC_URI="https://github.com/pyexcel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. DEPEND="dev-python/lxml"
  13. RDEPEND="${DEPEND}"
  14. BDEPEND=""
  15. DOCS=( README.rst CHANGELOG.rst CONTRIBUTORS.rst docs/ )
  16. distutils_enable_tests setup.py
  17. src_install() {
  18. distutils-r1_src_install
  19. }