python-doi-0.2.ebuild 727 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=setuptools
  5. PYTHON_COMPAT=( python3_{10..12} )
  6. inherit distutils-r1
  7. DESCRIPTION="Python package to work with Document Object Identifier (doi)"
  8. HOMEPAGE="https://github.com/papis/python-doi https://pypi.org/project/python-doi"
  9. #https://github.com/alejandrogallo/python-doi
  10. SRC_URI="https://github.com/papis/python-doi/archive/refs/tags/v0.2.tar.gz -> ${P}.tar.gz"
  11. LICENSE="GPL-3"
  12. SLOT="0"
  13. KEYWORDS="~amd64"
  14. DEPEND=""
  15. RDEPEND="${DEPEND}"
  16. BDEPEND=""
  17. DOCS=( AUTHORS.rst CONTRIBUTING.rst CHANGELOG.md LICENSE README.rst)
  18. distutils_enable_tests setup.py
  19. src_install() {
  20. distutils-r1_src_install
  21. }