python-markdownify-0.11.6.ebuild 906 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=setuptools
  5. PYTHON_COMPAT=( python3_{9..11} )
  6. inherit distutils-r1
  7. DESCRIPTION="Library to convert HTML to Markdown"
  8. HOMEPAGE="
  9. https://pypi.org/project/markdownify/
  10. https://github.com/matthewwithanm/python-markdownify
  11. "
  12. SRC_URI="https://github.com/matthewwithanm/python-markdownify/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  13. LICENSE="MIT"
  14. SLOT="0"
  15. KEYWORDS="~amd64"
  16. DEPEND=""
  17. RDEPEND="${DEPEND}"
  18. BDEPEND=""
  19. distutils_enable_tests pytest
  20. DOCS=( README.rst MANIFEST.in LICENSE )
  21. python_prepare_all() {
  22. # FIXME: issue #86 has been open upstream ini order to fix setup.py
  23. # find_packages() -> find_packages(exclude=["tests"]))
  24. # for the moment, we remove tests/
  25. rm -Rf tests/ || die
  26. distutils-r1_python_prepare_all
  27. }
  28. src_install() {
  29. distutils-r1_src_install
  30. }