python-markdownify-0.12.1.ebuild 807 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=setuptools
  5. PYTHON_COMPAT=( python3_{10..13} )
  6. inherit distutils-r1
  7. DESCRIPTION="Library to convert HTML to Markdown"
  8. HOMEPAGE="
  9. https://pypi.org/project/markdownify/
  10. https://github.com/matthewwithanm/python-markdownify
  11. "
  12. SRC_URI="https://github.com/matthewwithanm/python-markdownify/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  13. LICENSE="MIT"
  14. SLOT="0"
  15. KEYWORDS="~amd64"
  16. RDEPEND="
  17. dev-python/beautifulsoup4[${PYTHON_USEDEP}]
  18. dev-python/six[${PYTHON_USEDEP}]
  19. "
  20. distutils_enable_tests pytest
  21. DOCS=( README.rst MANIFEST.in LICENSE )
  22. python_prepare_all() {
  23. mv tests markdownify/tests || die
  24. distutils-r1_python_prepare_all
  25. }
  26. src_install() {
  27. distutils-r1_src_install
  28. }