square-1.0.ebuild 552 B

1234567891011121314151617181920212223
  1. # Copyright 2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit font
  5. DESCRIPTION="A TTF font designed to make characters fill a square space."
  6. HOMEPAGE="https://strlen.com/square/"
  7. SRC_URI="https://strlen.com/files/square.ttf"
  8. LICENSE="CC-BY-3.0" #Creative Commons Attribution 3.0 Unported licence
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~x86"
  11. IUSE=""
  12. S="${WORKDIR}"
  13. FONT_SUFFIX="ttf"
  14. src_install() {
  15. mkdir -p ${D}/usr/share/fonts/square/
  16. cp ${DISTDIR}/${PN}.ttf ${D}/usr/share/fonts/square/${PN}.ttf
  17. }