libtxc_dxtn-1.0.1.ebuild 654 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit multilib-minimal
  5. DESCRIPTION="Implementation of the S3 Texture Compression"
  6. HOMEPAGE="https://web.archive.org/web/20200923055707/https://cgit.freedesktop.org/~mareko/libtxc_dxtn/"
  7. SRC_URI="https://people.freedesktop.org/~cbrill/${PN}/${P}.tar.bz2"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. DEPEND="media-libs/mesa"
  12. RDEPEND="${DEPEND}"
  13. BDEPEND=""
  14. multilib_src_configure() {
  15. ECONF_SOURCE="${S}" econf
  16. }
  17. multilib_src_install_all() {
  18. default
  19. # libtxc_dxtn is installed as a module (plugin)
  20. find "${D}" -name '*.la' -delete || die
  21. }