bob-bin-9999.ebuild 696 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. UPSTREAM_PN="bob.com"
  5. MY_PN="bob"
  6. S=${WORKDIR}/
  7. DESCRIPTION="B·o·B, an universal & secure peer-to-peer file-transfer (binary version)"
  8. HOMEPAGE="
  9. https://bob.osau.re/
  10. https://github.com/dinosaure/bob
  11. "
  12. SRC_URI="https://builds.osau.re/job/bob/build/latest/f/bin/${UPSTREAM_PN} -> ${MY_PN}"
  13. LICENSE="MIT"
  14. SLOT="0"
  15. KEYWORDS="~amd64"
  16. DEPEND=""
  17. RDEPEND="${DEPEND}"
  18. BDEPEND=""
  19. src_install() {
  20. exeinto /usr/bin
  21. newexe ${DISTDIR}/"${MY_PN}" "${MY_PN}"
  22. }
  23. pkg_postinst() {
  24. einfo "Turn bob.com into a truly native program (assimilation)"
  25. su -s /bin/sh -c "/usr/bin/bob --assimilate"
  26. }