btop-1.2.8.ebuild 578 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="A complete monitor of machine resources"
  5. HOMEPAGE="https://github.com/aristocratos/btop"
  6. SRC_URI="https://github.com/aristocratos/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="Apache-2.0"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. DEPEND=""
  11. RDEPEND="${DEPEND}"
  12. BDEPEND=">=sys-devel/gcc-10"
  13. src_prepare() {
  14. default
  15. }
  16. src_compile() {
  17. emake
  18. }
  19. src_install() {
  20. emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
  21. dodoc README.md CHANGELOG.md
  22. }