find-cursor-1.7.ebuild 617 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Simple XLib program to highlight the cursor position"
  5. HOMEPAGE="https://github.com/arp242/find-cursor"
  6. SRC_URI="https://github.com/arp242/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. DEPEND="
  11. x11-libs/libXcomposite
  12. x11-libs/libXdamage
  13. x11-libs/libXrender
  14. x11-libs/libX11"
  15. RDEPEND="${DEPEND}"
  16. BDEPEND=""
  17. src_prepare() {
  18. eapply "${FILESDIR}"/${P}-makefile-destdir.patch
  19. eapply_user
  20. }
  21. src_install() {
  22. emake DESTDIR="${D}" install
  23. }