fire-0.7.0.ebuild 988 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. DISTUTILS_USE_PEP517=setuptools
  5. PYTHON_COMPAT=( python3_{10..13} )
  6. inherit distutils-r1
  7. MY_PN=python-${PN}
  8. MY_P=${MY_PN}-${PV}
  9. S=${WORKDIR}/${MY_P}
  10. DESCRIPTION="Library for automatically generating CLIs from any Python object"
  11. HOMEPAGE="
  12. https://github.com/google/python-fire
  13. https://pypi.org/project/fire/"
  14. if [[ "${PV}" == *9999 ]]; then
  15. inherit git-r3
  16. EGIT_REPO_URI="https://github.com/google/python-fire"
  17. else
  18. SRC_URI="https://github.com/google/python-fire/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.tar.gz"
  19. fi
  20. LICENSE="Apache-2.0"
  21. SLOT="0"
  22. KEYWORDS="~amd64 ~x86"
  23. DEPEND=""
  24. RDEPEND="dev-python/termcolor[${PYTHON_USEDEP}]"
  25. BDEPEND="test? (
  26. dev-python/hypothesis[${PYTHON_USEDEP}]
  27. dev-python/Levenshtein[${PYTHON_USEDEP}]
  28. )"
  29. DOCS=( CONTRIBUTING.md LICENSE MANIFEST.in README.md docs/ )
  30. distutils_enable_tests setup.py
  31. src_install() {
  32. distutils-r1_src_install
  33. }