btop-1.4.0.ebuild 894 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit toolchain-funcs optfeature
  5. DESCRIPTION="A complete monitor of machine resources"
  6. HOMEPAGE="https://github.com/aristocratos/btop"
  7. SRC_URI="https://github.com/aristocratos/btop/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="Apache-2.0"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. DEPEND=""
  12. RDEPEND="${DEPEND}"
  13. BDEPEND="|| ( >=sys-devel/gcc-10 >=sys-devel/clang-16.0.0 )"
  14. src_prepare() {
  15. default
  16. }
  17. #TODO: I should add something here to manage the GPU compatibility
  18. #+ may also need dependencies
  19. #src_configure() {
  20. # GPU_SUPPORT / -DBTOP_GPU ; default=true
  21. # RSMI_STATIC / -DBTOP_RSMI_STATIC ; AMD, default=true
  22. # FORTIFY_SOURCE ; default=false
  23. #}
  24. src_compile() {
  25. emake
  26. }
  27. src_install() {
  28. emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
  29. dodoc README.md CHANGELOG.md
  30. }